httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Vinicius Petrucci" <vpetru...@ic.uff.br>
Subject Re: mod_proxy_balancer
Date Tue, 04 Sep 2007 19:58:57 GMT
Hi,

As I said before, your last patch didn't solve the bug because the
variable you created (worker_is_initialized) always gets zero value.

I've created the patches attached. The solution was to simply move the
code section that set lbfactor, lbstatus, and lbset to the original
configuration inside the function ap_proxy_initialize_worker_share()
in proxy_util.c.

It works using my httpd-trunk version. Could you guys confirm if it is correct?

Vinicius

On 04/09/07, Vinicius Petrucci <vpetrucci@ic.uff.br> wrote:
> I don't know why, but each time a new child is created the variable
> worker_is_initialized is 0.
>
> Therefore, the problem of reseting to the original configuration is not solved.
>
> I'm debugging more on this...
>
> On 04/09/07, Ruediger Pluem <rpluem@apache.org> wrote:
> >
> >
> > On 09/03/2007 11:40 PM, Vinicius Petrucci wrote:
> > > Ruedinger:
> > >
> > > In your patch, I think the call PROXY_WORKER_IS_INITIALIZED(workers)
> > > before initialize the pointer *workers is causing that error log:
> > >
> > > [Mon Sep 03 18:32:34 2007] [notice] child pid 5225 exit signal
> > > Segmentation fault (11)
> >
> > Sorry my fault. Can you please try the attached one please?
> >
> > >
> > > But if I call the method: ap_proxy_initialize_worker_share(conf,
> > > workers, s); before, I always get worker initialized...
> >
> > Which is why I called it before :-).
> >
> > Regards
> >
> > RĂ¼diger
> >
> >
> >
>
>
> --
> Vinicius Tavares Petrucci
> home page: http://www.ic.uff.br/~vpetrucci
>


-- 
Vinicius Tavares Petrucci
home page: http://www.ic.uff.br/~vpetrucci

Mime
View raw message