httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Guenter Knauf <fua...@apache.org>
Subject Question about httpd / APR version relationship
Date Wed, 09 May 2007 23:33:31 GMT
Hi all,
currently from what I see we use:

Apache 2.0.x -> has to use APR 0.9.x
Apache 2.2.x -> has to use APR 1.2.x
Apache 2.3.x -> has to use APR 1.3.x

is this now a mandatory relationship, or is it valid to:

build Apache 2.2.x with APR 1.3.x
build Apache 2.3.x with APR 1.2.x

I assume on Linux the configure magic checks for that, but on NetWare and Win32 one could
mix up....
I ask because I think of a makefile hack to avoid non-valid builds....

greets, Guenter.



Mime
View raw message