httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ruediger Pluem <rpl...@apache.org>
Subject Re: ProxyTimeout does not work as documented
Date Sat, 19 May 2007 19:22:40 GMT


On 05/19/2007 04:07 PM, Eric Covener wrote:
> On 5/18/07, Ruediger Pluem <rpluem@apache.org> wrote:
> 
>> Currently ProxyTimeout does not work as documented as the default
>> value is not
>> 300 secs, but the Timeout setting of the server. The question to me is
>> now:
>> What should be fixed?
>>
>> - Documentation (such that it matches the code)
>> - Code (such that it matches the documentation)
> 
> 
> Acting like a connection timeout only for me proxying HTTP on 2.2.4. I
> think I've read about similiar befuddlements on assorted PRs.
> 
> It is raised a secondary issue here:
> http://issues.apache.org/bugzilla/show_bug.cgi?id=11540

I know :-). This is the next issue I want to address once the issue above is solved.
In 2.2.x / trunk ProxyTimeout is ignored almost completely (it is only used for CONNECT).
Workers either use their own timeout set via the worker timeout parameter or
they use the server timeout as default, if no worker timeout is set. Although this (nearly)
works as documented I plan to change this to let the workers use the ProxyTimeout setting
as a default value in the case that they do not have their own timeout set via a parameter.
This sounds a lot more sane to me instead of using the server timeout here as a default value.

Regards

RĂ¼diger

Mime
View raw message