httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "William A. Rowe, Jr." <wr...@rowe-clan.net>
Subject Re: Windows Vista support?
Date Wed, 02 May 2007 08:46:16 GMT
Steve Hay wrote:
> Has any development been done for supporting Windows Vista yet, or is it
> planned by anyone soon?

Hi Steve.  Do you mean are we accepting patches to solve problems on Vista?
Sure.  Do you mean is there a person assigned to resolve such issues?  No
(and that's true of all platforms, all processors, all versions).  Version
support is based on users testing, patching, and adopting the patches.

So if you are asking if I (a win32 guy) am planning to look at this; the
answer is probably not.  I haven't landed long enough in one place to get
the longhorn server beta flying yet, once I do, will pay attention to that
platform.  Since Vista isn't a server OS (is horribly tuned for non-gui
applications) I'm not feeling an urge to beat on it (certainly not to
install Vista myself).  Since longhorn server will be a superset of Vista,
with same/similar issues, vista should come "for free".

> The reason I ask is that the server doesn't seem to run as a service on
> Windows Vista. I logged this as a bug and asked about it on the user
> mailing too recently, but had no reply to either, so I'm guessing that
> most Win32 people aren't using Vista yet.
> 
> http://issues.apache.org/bugzilla/show_bug.cgi?id=41611

Well I closed this bug as wontfix - I doubt anyone is about to write the
patches to apache 1.3 for windows vista.  It's a dead and buried horse.

You would be better off annotating the appropriate bug about apache 2.2
compatibility with vista and add your observations there.

Mime
View raw message