httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Plüm, Rüdiger, VF-Group <ruediger.pl...@vodafone.com>
Subject Re: Repeated NTLM authentication boxes for OWA 2k3 with Reverse Proxying Apache 2.2
Date Thu, 29 Mar 2007 06:03:43 GMT
Maybe this still works if you use the prefork MPM, because in this case the connection pool
per
server process is limited to 1 connection. Please let us know if this works such that this
can be added
as a comment to http://issues.apache.org/bugzilla/show_bug.cgi?id=39673.
 
Regards
 
Rüdiger

	-----Ursprüngliche Nachricht-----
	Von: MKhurana@IN.Safenet-inc.com [mailto:MKhurana@IN.Safenet-inc.com] 
	Gesendet: Donnerstag, 29. März 2007 07:03
	An: dev@httpd.apache.org
	Betreff: RE: Repeated NTLM authentication boxes for OWA 2k3 with Reverse Proxying Apache
2.2
	
	
	         Hi Rüdiger/all
	 
	         Thanks for the reply 
	 
	         But is there any workaround available for using NTLM with MPM worker or a way to
turn off connection pooling.
	         
	         Regards
	         Manmeet Singh
	           
	         
	      

		-----Original Message-----
		From: Plüm, Rüdiger, VF-Group [mailto:ruediger.pluem@vodafone.com]
		Sent: Wednesday, March 28, 2007 4:34 PM
		To: dev@httpd.apache.org
		Subject: Re: Repeated NTLM authentication boxes for OWA 2k3 with Reverse Proxying Apache
2.2
		
		
		NTLM currently does not work with httpd 2.2.x and reverse proxy configurations due to the
fact that httpd 2.2.x
		uses connection pooling for its backend connections. NTLM does not respect the fact that
HTTP is a stateless
		protocol. Thus is fails.
		 
		See also: http://issues.apache.org/bugzilla/show_bug.cgi?id=39673
		 
		Regards
		 
		Rüdiger

			-----Ursprüngliche Nachricht-----
			Von: MKhurana@IN.Safenet-inc.com  
			 Gesendet: Mittwoch, 28. März 2007 12:56
			An: dev@httpd.apache.org
			Betreff: Repeated NTLM authentication boxes for OWA 2k3 with Reverse Proxying Apache 2.2
			
			


			Hi all 

			I have made following setup with Apache 2.2 


			Client <---https---> Apache 2.2.3 <--------> OWA 2k3 server 

			in my conf I have 

			Listen 172.25.12.146:80 
			<VirtualHost 172.25.12.146:80> 
			   DocumentRoot "/myroot/abc/" 
			   ServerName application.owa.com 
			        <IfDefine PROXY> 
			          ProxyPass        / http://application.owa.com/ 

			        ProxyPassReverse / http://application.owa.com/ 
			        ProxyPassReverse / http://application.owa.com:80/ 
			        ProxyPassReverse / http://172.25.11.33/ 
			        ProxyPassReverse / http://172.25.11.33:80/ 
			     </IfDefine> 
			</VirtualHost> 



			but when I try to connect I get repeated NTLM authentication boxes but OWA resource is
available after many attempts.If I click any other link on OWA it again asks for NTLM authentication.


			Also the very same httpd.conf and network setup is working fine with Apache 2.0.53 hust
replacing the httpd 

			Is there any change in the two version regarding the same .... 

			Or if anyone has experienced this .Please help......... 


			Thanks/regards 
			 Manmeet Singh 


			The information contained in this electronic mail transmission may be privileged and confidential,
and therefore, protected from disclosure. If you have received this communication in error,
please notify us immediately by replying to this message and deleting it from your computer
without copying or disclosing it.
			


	The information contained in this electronic mail transmission may be privileged and confidential,
and therefore, protected from disclosure. If you have received this communication in error,
please notify us immediately by replying to this message and deleting it from your computer
without copying or disclosing it.
	


Mime
View raw message