httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Niklas Edmundsson <ni...@acc.umu.se>
Subject Re: Coding style
Date Tue, 03 Oct 2006 07:26:59 GMT
On Mon, 2 Oct 2006, Garrett Rooney wrote:

> Or the even more readable:
>
> rv = do_something(args);
> if (rv == APR_SUCCESS) {
>
> }

+1 for simple code like this.

It comes naturally when you need to do stuff like
rv = dostuff(...);
if(rv != APR_SUCCESS && rv != whatever) {
...

and is also less likely to cause ugly linewraps when using
functions_with_long_names(and, a, large, list, of, arguments) ...

/Nikke
-- 
-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-
  Niklas Edmundsson, Admin @ {acc,hpc2n}.umu.se      |     nikke@acc.umu.se
---------------------------------------------------------------------------
  Sexy: Uses feather.  Kinky: Uses entire chicken.
=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=

Mime
View raw message