httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nick Kew <n...@webthing.com>
Subject Re: compatibility questions 2.2.x <--> 2.0.x
Date Fri, 06 Oct 2006 13:21:21 GMT
On Friday 06 October 2006 14:02, Markus Litz wrote:
> Hello,
>
> i change some code to get a apache 2.0.X module running under 2.2.x.
> For example i had to change the following line:
> apr_sockaddr_port_get(&port, r->connection->local_addr);
>
> to:
> port = r->connection->local_addr->port;

Hmmm.  I wasn't aware of that one.  Thumbs down to whoever broke it:-)

> Now, is there a way to get it working under both apache versions?

I've got a number of modules working with both.  For those which don't
work cleanly due to problems like the above, you can use the
preprocessor with #ifdef ... #else ... #endif to deal with that
kind of thing.

Maybe we could come up with a standard bunch of macros to
#include for that kind of thing.  But I suspect that would be more
work than doing it ad-hoc, precisely because we don't have a
handy list of issues.


-- 
Nick Kew

Mime
View raw message