httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jess Holle <je...@ptc.com>
Subject Re: Apache 2.2.2 + CGI -> Child Exit?!?
Date Fri, 14 Jul 2006 14:06:01 GMT
Note: In case anyone thinks I posted to the wrong group, I'm really 
looking for:

    * Developer-level info as to if/how a CGI program could cause an
      Apache worker process death in 2.2.2
    * Developer-level pointers on where in mod_cgi we should place
      breakpoints, logging, or the like to try to determine what's going
      wrong -- or if this even makes sense

Of course if there is some out-of-the-box verbosity option I'm missing 
to help with this, I'm all ears.  I used LogLevel debug, of course, but 
it told me nothing new.

--
Jess Holle

Jess Holle wrote:
> With Apache 2.2.2 on Windows, we're getting the following error:
>
>   Parent: child process exited with status 3221225477 -- Restarting.
>
> Whenever URLs are requested that execute CGI that was working 100% 
> fine in Apache 2.0.x.
>
> This leads me to ask:
>
>     * How can a CGI program kill an Apache worker process?
>     * How can this happen only in Apache 2.2.2, but not in any 2.0.x
>       that we've tried.
>
> The CGI in question is a 3rd-party application for which we have 
> neither source nor official Apache 2.2.2 support.  Yet I would think 
> that CGI should just work irrespective, right?  Or at least it 
> shouldn't kill the Apache worker processes, right?  Could this be an 
> issue in 2.2.2's mod_cgi?
>
> To make matters weirder the issue went away for one developer, but he 
> does not know what he did to make it go away nor can anyone else seem 
> to reproduce this.
>
> --
> Jess Holle
>


Mime
View raw message