httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jorge Schrauwen" <jorge.schrau...@gmail.com>
Subject Re: IPV6 enabled on supplied Windows 32 binary?
Date Wed, 12 Jul 2006 18:12:41 GMT
Indeed i can't get mine to bind on IPv6 aswel... strange since i was sure i
had it listening on IPv6!

I get a
[Wed Jul 12 20:10:16 2006] [crit] (OS 11004)The requested name is valid, but
no data of the requeste
d type was found.  : alloc_listener: failed to set up sockaddr for
[fe80::211:d8ff:fe94:8881%4]
Syntax error on line 18 of S:/Apache2/conf/httpd.conf:
Listen setup failed

this is actually bad since i access my computer via IPv6 in school! that
explains why it said it was down the last week of school.

Hmmz maybe this is a 2.2 isseus!

PS: what OS are you running? I'm on XP x64...

On 7/12/06, Warren Lewis <Warren.Lewis@sas.com> wrote:
>
> Testing in a IPV6 environment fails. :-(
>
> Also shouldn't I see
>
> -D APR_HAVE_IPV6 (IPv4-mapped addresses enabled)
> or
> -D APR_HAVE_IPV6 (IPv4-mapped addresses disable)
>
> in the log if IPV6 is enabled?
>
>
> I attempted to build the executable myself with Visual Studio 2005, but, I
> can't get
> a working httpd.exe. First it complained about not being able to find
> msvcrt80.dll,
> which was easy to remedy.
> But, now httpd -V fails with the error:
> The application failed to initialize properly (0x80000003). Click on OK to
> terminate the application.
>
>
> Any additional pointers/thoughts?
>
> thanks - Warren
> ________________________________
>
> From: Jorge Schrauwen [mailto:jorge.schrauwen@gmail.com]
> Sent: Sunday, July 09, 2006 6:53 PM
> To: dev@httpd.apache.org
> Subject: Re: IPV6 enabled on supplied Windows 32 binary?
>
>
> I'm pretty sure i compiled mine with IP V6 and it doesn't show for me
> aswel.
> SO just test it and see if it works
>
>
> On 7/10/06, Warren Lewis < Warren.Lewis@sas.com <mailto:
> Warren.Lewis@sas.com> > wrote:
>
>         Hi,
>
>            Am I mistaken or does the supplied downloadable version of
> Apache 2.2.2
>         not support IPV6?
>
>
>         C:\Program Files\Apache Software Foundation\Apache2.2\bin>httpd -V
> Server version: Apache/2.2.2
>         Server built:   Apr 29 2006 18:32:31
>         Server's Module Magic Number: 20051115:2 Server loaded:  APR 1.2.7,
> APR-Util 1.2.7 Compiled using: APR 1.2.7, APR-Util 1.2.7
>         Architecture:   32-bit
>         Server MPM:     WinNT
>           threaded:     yes (fixed thread count)
>             forked:     no
>         Server compiled with....
>         -D APACHE_MPM_DIR=3D"server/mpm/winnt"
>         -D APR_HAS_SENDFILE
>         -D APR_HAS_MMAP
>         -D APR_HAS_OTHER_CHILD
>         -D AP_HAVE_RELIABLE_PIPED_LOGS
>         -D DYNAMIC_MODULE_LIMIT=3D128
>         -D HTTPD_ROOT=3D"/apache"
>         -D SUEXEC_BIN=3D"/apache/bin/suexec"
>         -D DEFAULT_SCOREBOARD=3D"logs/apache_runtime_status"
>         -D DEFAULT_ERRORLOG=3D"logs/error.log"
>         -D AP_TYPES_CONFIG_FILE=3D"conf/mime.types"
>         -D SERVER_CONFIG_FILE=3D"conf/httpd.conf"
>
>
>         Shouldn't APR_HAVE_IPV6 be in there somewhere?
>
>         thanks - Warren
>
>
>
>
>
>
>
> --
> ~Jorge
>



-- 
~Jorge

Mime
View raw message