httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From hunter <theanti...@gmail.com>
Subject Re: New Windows build - Apache 2.2.3
Date Sun, 30 Jul 2006 21:15:16 GMT
On 7/30/06, Jorge Schrauwen <jorge.schrauwen@gmail.com> wrote:
> ah using visual studio 2005?
> Try using the unix source instead... wrowe posted a notice about this.
>
> On 7/30/06, hunter <theantigod@gmail.com> wrote:
> > I am getting an error while building Apache 2.2.3 for Windows...
> >
> >    Creating library .\Release\mod_unique_id.lib and object
> > .\Release\mod_unique_id.exp
> >         nmake -nologo -f mod_usertrack.mak   CFG="mod_usertrack -
> > Win32 Release" RECURSE=0
> >         rc.exe /l 0x409 /fo"Debug/mod_usertrack.res" /i
> > "../../include" /i "../../srclib/apr/include" /i "\asf
> > -build\build-2.2.3\build\win32" /d "_DEBUG" /d
> > BIN_NAME="mod_usertrack.so" /d LONG_NAME="usertrack_module for Apache"
> > ..\..\build\win32\httpd.rc fatal error RC1109: error creating
> > Debug/mod_usertrack.res
> > NMAKE : fatal error U1077: 'rc.exe' : return code '0x1'
> > Stop.
> > NMAKE : fatal error U1077: 'C:\MSVC7\Vc7\bin\nmake.exe' : return code '0x2'
> > Stop.
> > NMAKE : fatal error U1077: 'C:\MSVC7\Vc7\bin\nmake.exe' : return code '0x2'
> > Stop.
> >
> > Any suggestions...
> >
> > Chris Lewis
> >
>
>
> --
> ~Jorge
>

I may not be correct but I understood Bill's email to say that the
problem affected those who compile with the IDE, while I compile from
the command line.

I tried compiling with SDK 2003 R2 (newer complier) but that made no
difference.

Trying to compile with unix source results with an immediate failure
to find srclib due to forward slashes that are not recognized by
Windows.

I think there is something wrong with mod_usertrack.mak - notice the /d _DEBUG.

I have tried to fix the makefile but I have still not fixed it.

Chris Lewis

Mime
View raw message