httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Phil Endecott <spam_from_apache_...@chezphil.org>
Subject Compiling a C++ module with g++ on Solaris
Date Sun, 11 Jun 2006 17:17:09 GMT
Dear All,

I'm the author of Anyterm (http://anyterm.org/) which uses an Apache 
module written in C++.  This works OK on Linux.  However, a user has 
attempted to compile it on Solaris and it fails at run time. 
Specifically, the first time that any C++ memory allocation stuff 
happens - it creates a std::string in the post_config hook function - it 
segfaults deep inside libstdc++.

This user is using g++ 3.4.3 and the Sun linker on Solaris 10 x86.  I'm 
curous to know if any readers have any experience compiling C++ Apache 
modules on this platform, and whether there are any gotchas to look out for.

Is it possible that there is some libstdc++ initialisation that hasn't 
happened?  I could imagine that this would require special support from 
the linker or the dlopen stuff, and that that behaves differently with 
Sun's libc and linker than on Linux.

Any ideas?  He has tried with 2.0.5? and 2.2.? with the same result.

Cheers,

Phil.




Mime
View raw message