httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "William A. Rowe, Jr." <>
Subject Re: RFC: rename mod_cache to mod_http_cache
Date Wed, 03 May 2006 19:32:06 GMT
Brian Akins wrote:
> Not wanting to stir the huge pot o' stuff that is going on here, but 
> what are the thoughts of renaming mod_cache to mod_http_cache? mod_cache 
> is http specific.  This would follow the general ide that mod_proxy uses.
> I am not suggesting changing any functionality at this time, simply 
> renaming it to a more suitable name.

Not in 2.2 branch, but in trunk?  The issue is that it's half httpd, and
half generic.  Let me mull this over.

If we layer it, I can entirely agree that there should be a mod_http_cache
that's entirely concerned with the content negotation handshake of http.
But in all other respects, mod_cache is equally useful for other protocols
such as mod_ftp (it takes advantage of it now, only with one possible
variant because ftp doesn't speak in variants.)


View raw message