httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Graham Leggett <>
Subject Re: Possible new cache architecture
Date Thu, 27 Apr 2006 21:25:32 GMT
Brian Akins wrote:

> The components:
> mod_http_cache: what mod_cache is currently
> mod_cache: a generic caching module - provides glue between providers 
> and other modules.  Think mod_dbd...
> cache providers: disk, mem, memcache, mysql, etc.

This sounds like a refactoring job, which is a good idea.

I think step one would be to rename mod_cache to be mod_http_cache as 
you suggest, then create a blank mod_cache, followed by some refactoring 
of the generalised methods and cache hooks into mod_cache.

I think this exercise should uncover what needs to move, and what needs 
to be changed.

A question to ponder is just how generic should the cache be. An HTTP 
cache requires cache entries containing data and headers, either of 
which can be updated separately. As a result, the typical "cache a blob 
of data" interface isn't going to work, and needs to be kept in mind 
when looking at the cache interfaces.


View raw message