httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Brian Akins <>
Subject Re: generalized cache modules
Date Tue, 18 Apr 2006 21:18:10 GMT
Graham Leggett wrote:
> Brian Akins wrote:
>> Was playing with memcached and mod_cache when I had some thoughts.
>> -mod_cache should be renamed to mod_http_cache
>> -new modules mod_cache (or some inventive) name would be a more 
>> general purpose cache)
> I would say that mod_cache would need to be split into mod_cache 
> (general protocol agnostic cache as you described) and mod_cache_http 
> (HTTP cache), I suspect the existing mod_cache code has hooks for both 
> that would need to be separated out from one another.

Should this be a SoC project or normal httpd-dev project?  Is there any 
interest in this?  I can help either way.  This would make each 
individual modules much easier to maintain while giving us greater 
flexibility (mod_cache_dbd, mod_cache_shm, mod_ftp_cache, mod_ssl 
session cache, mod_ip_tracker...)

I would add the "feature request" that we can stack the caches. IE, 
check disk, then memcache.

Brian Akins
Lead Systems Engineer
CNN Internet Technologies

View raw message