httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Graham Leggett <>
Subject Re: generalized cache modules
Date Tue, 18 Apr 2006 19:51:46 GMT
Brian Akins wrote:

> Was playing with memcached and mod_cache when I had some thoughts.
> -mod_cache should be renamed to mod_http_cache
> -new modules mod_cache (or some inventive) name would be a more general 
> purpose cache)

I would say that mod_cache would need to be split into mod_cache 
(general protocol agnostic cache as you described) and mod_cache_http 
(HTTP cache), I suspect the existing mod_cache code has hooks for both 
that would need to be separated out from one another.

> So mod_http_cache would simply be a front end to mod_cache providers. 
> These providers do not have to know anything about http, only how to 
> fetch, store, expire, etc. "objects."



View raw message