httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "William A. Rowe, Jr." <>
Subject Re: [VOTE] Release 2.2.1 as GA
Date Mon, 03 Apr 2006 05:26:32 GMT
Colm MacCarthaigh wrote:
> On Sun, Apr 02, 2006 at 05:17:00PM +0200, Ruediger Pluem wrote:
>>On 04/02/2006 05:06 PM, Colm MacCarthaigh wrote:
>>>Adding an ABI doesn't break ABI backwards-compat, so it should be o.k.
>>But httpd 2.2.1 would not compile with apr-util below 1.2.7 on windows.
> That's allowed I think, and I think there are precendents for that too,
> it's only ABI compatibility for modules that we have to worry about.

Yea - it's allowed.  When we decided on 'binary compatibility', we effectively
limited ourselves from updating httpd-2.0 to run on apr-1 instead of apr-0.9.
how many features in the evolution of httpd-2.0.x require the incremental
releases of apr-0.9.x?

OTOH - we can't jump to apr-1, reason being that many folks build third party
addins to httpd which require predictable, binary compatibility from subversion
bump to bump.  So to avoid breaking third party modules, we won't be able to
jump from apr-1 to, say, apr-2 until a later httpd-2.x verison.

>>So I guess this part of the code should be conditional and only active
>>either on non windows (BTW: anyone tested if other non UNIX OS are affected
>>by this? Netware?) or if apr-util >= 1.2.7 as I remember myself that
>>httpd 2.2.x should compile with any apr / apr-util 1.2.x.
> We could ifdef it for that easily enough, so that's a good idea :)

Nah, this was a platform bug all the time on Windows.  So they weren't building
an acceptable package that matched our doxygen documented api.  True?


View raw message