httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "William A. Rowe, Jr." <wr...@rowe-clan.net>
Subject Re: [VOTE] Release 2.2.1 as GA
Date Mon, 03 Apr 2006 05:23:06 GMT
Ruediger Pluem wrote:
> 
> On 04/02/2006 05:19 AM, William A. Rowe, Jr. wrote:
> 
>>>Can someone on win32 PLEASE update the .dsp file for apr-util?
>>
>>Glad to
> 
> Does this mean that httpd 2.2.1 does not run with apr-util below 1.2.6
> on windows? Is this desired?

IMHO - this was an outright Win32-specific bug on all versions of apr-util
since apu_version_get was introduced :-/  Unfortunately, as someone hinted
on the #apr channel, it sometimes seems like until a new API is adopted by
the httpd project, it's rarely exercised elsewhere :(

AFA version mismatches, I see no issue; nobody could possibly run half the
1.2 versions of apr with httpd on OS/X - due to the poll/kqueue issues on
and off throughout the development of that branch and the platform's quirks.
Is this a huge issue?  I doubt it.

Almost anyone obtaining httpd.exe obtains a libapr.dll/libaprutil.dll in the
same package/binaries/installer.  So this can't really become a big issue.

Bill

Mime
View raw message