httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joe Orton <jor...@redhat.com>
Subject Re: When did this break?
Date Mon, 03 Apr 2006 15:24:00 GMT
On Mon, Apr 03, 2006 at 08:53:24AM +0100, Joe Orton wrote:
> What's really needed here is a "--with-included-apr"-type flag which 
> forces use of the bundled sources over installed versions, rather than 
> trying to overload --with-apr to do that.

e.g. this, slightly hacky but does it solve the problem you were having?

Index: configure.in
===================================================================
--- configure.in	(revision 388210)
+++ configure.in	(working copy)
@@ -61,8 +61,16 @@
 
 echo $ac_n "${nl}Configuring Apache Portable Runtime library ...${nl}"
 
-APR_FIND_APR("$srcdir/srclib/apr", "./srclib/apr", 1, 1)
+AC_ARG_WITH(included-apr,
+APACHE_HELP_STRING(--with-included-apr,Use bundled copies of APR/APR-Util))
 
+if test "x$with_included_apr" = "xyes"; then
+   apr_found=reconfig
+   apr_config="$srcdir/srclib/apr/apr-1-config"
+else 
+   APR_FIND_APR("$srcdir/srclib/apr", "./srclib/apr", 1, 1)
+fi
+
 if test "$apr_found" = "no"; then
   AC_MSG_ERROR([APR not found.  Please read the documentation.])
 fi
@@ -89,7 +97,12 @@
 
 echo $ac_n "${nl}Configuring Apache Portable Runtime Utility library...${nl}"
 
-APR_FIND_APU("$srcdir/srclib/apr-util", "./srclib/apr-util", 1, 1)
+if test "x$with_included_apr" = "xyes"; then
+   apu_found=reconfig
+   apu_config="${srcdir}/srclib/apr-util/apu-1-config"
+else 
+   APR_FIND_APU("$srcdir/srclib/apr-util", "./srclib/apr-util", 1, 1)
+fi
 
 if test "$apu_found" = "no"; then
   AC_MSG_ERROR([APR-util not found.  Please read the documentation.])




Mime
View raw message