httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Colm MacCarthaigh <c...@stdlib.net>
Subject Re: [VOTE] Release 2.2.1 as GA
Date Sun, 02 Apr 2006 17:19:05 GMT
On Sun, Apr 02, 2006 at 05:17:00PM +0200, Ruediger Pluem wrote:
> 
> 
> On 04/02/2006 05:06 PM, Colm MacCarthaigh wrote:
> 
> > 
> > Adding an ABI doesn't break ABI backwards-compat, so it should be o.k.
> 
> But httpd 2.2.1 would not compile with apr-util below 1.2.7 on windows.

That's allowed I think, and I think there are precendents for that too,
it's only ABI compatibility for modules that we have to worry about.

> So I guess this part of the code should be conditional and only active
> either on non windows (BTW: anyone tested if other non UNIX OS are affected
> by this? Netware?) or if apr-util >= 1.2.7 as I remember myself that
> httpd 2.2.x should compile with any apr / apr-util 1.2.x.

We could ifdef it for that easily enough, so that's a good idea :)

-- 
Colm MacCárthaigh                        Public Key: colm+pgp@stdlib.net

Mime
View raw message