httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Max Bowsher <ma...@ukf.net>
Subject Execution of check_user_id and auth_checker for all requests in 2.3 vs. only those with AuthType and Require in 2.2
Date Thu, 02 Mar 2006 16:23:45 GMT
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

In httpd-2.2, the check_user_id and auth_checker hooks are only invoked
for requests to which both an AuthType and at least one Require
directive apply.

In httpd-2.3, the check_user_id and auth_checker hooks run unconditionally.


I'm seeking confirmation that the above is an intentional design change.
If it is, perhaps someone could add the text of the first two paragraphs
of this email to the "Module Developer Changes" section of
'docs/manual/new_features_2_4.xml'.

Thanks,
Max.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.1 (Cygwin)

iD8DBQFEBxwRfFNSmcDyxYARAjhkAJ453P9oBnAzf/r2nFgfFuNTc4C5gACggzBV
gFlJuNC2woh6ZRmP/qk/KjE=
=V5pl
-----END PGP SIGNATURE-----

Mime
View raw message