httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Plüm, Rüdiger, VIS <ruediger.pl...@vodafone.com>
Subject AW: Problem: compiling mod_tidy with Apache 2.2
Date Thu, 19 Jan 2006 14:36:58 GMT


> -----Ursprüngliche Nachricht-----
> Von: Sierk Bornemann 
> 

[..cut..]

> ------
> 
> APR_BRIGADE_FOREACH does not longer exist, so there must be a 
> short fix 
> reflecting this.

The macro APR_BRIGADE_FOREACH is marked deprecated in apr-util 0.9.x
which is used by Apache 2.0.x for quite a long time (3.5 years,
see http://svn.apache.org/viewcvs.cgi?rev=58680&view=rev)
Thus it is not contained in apr-util 1.2.2 which is used by Apache
httpd 2.2.0. So please use different code to iterate over a brigade
as shown in the comments above the definition of APR_BRIGADE_FOREACH
in apr-util 0.9.x.

Regards

Rüdiger


[..cut..]

Mime
View raw message