httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sierk Bornemann <sie...@gmx.de>
Subject Problem: compiling mod_tidy with Apache 2.2
Date Thu, 19 Jan 2006 14:28:34 GMT
Hi!

I am the project maintainer of the Apache2 module mod_tidy 
(http://mod-tidy.sourceforge.net/), and there seems to be a problem 
compiling mod_tidy with Apache 2.2, because API has changed from 
Apache2.0 to Apache2.2:

Compiler error messages:
------
src/mod_tidy.c: In function 'mod_tidy_filter':
src/mod_tidy.c:189: warning: implicit declaration of function 
'APR_BRIGADE_FOREACH'
src/mod_tidy.c:189: error: expected ';' before '{' token
src/mod_tidy.c:154: warning: unused variable 'r'
apxs:Error: Command failed with rc=65536
------

APR_BRIGADE_FOREACH does not longer exist, so there must be a short fix 
reflecting this.

I have a short patch here, which compiles well under apache2.0.55 and 
which lets to a functionable binary under Linux (OpenSuse), but I have 
no possibility yet to check, if it also compiles and works with apache2.2.

For convenience, I have attached the little patch as a Unix diff to this email.
The source tarball of mod_tidy is available on: 
http://mod-tidy.sourceforge.net/src/
Is here anybody, who can help and have a look into the source and the 
patch or propose a better patch to solve the problem?


Thanks in advance,
Sierk Bornemann

Sierk Bornemann | Hannover | Germany
e-mail:  sierkb@gmx.de
URL:     http://sierkbornemann.de/ 
Mime
View raw message