httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "William A. Rowe, Jr." <wr...@rowe-clan.net>
Subject Re: Apache 2.2.0 on Win32
Date Wed, 11 Jan 2006 20:27:53 GMT
Fenlason, Josh wrote:
> Yeah, I stumbled upon depends.exe this morning.  I used it on the 2k3
> box and found out that it couldn't find msjava.dll (Why is this needed
> for Apache?) and msvcr80.dll.  I copied them from the working XP box
> into <apache_home>\bin.  It found the dlls, but I still get the same
> error.

Interesting.  I would be especially interested in knowing which .dll then
requires msjava.dll?  Follow the depends tree to let us know.

> 	Error: The Side-by-Side configuration information in
> "c:\apache22\bin\HTTPD.EXE" contains 	errors. This application has
> failed to start because the application configuration is
> incorrect. Reinstalling the application may fix this problem (14001).

Apparently there might be some additional flags that have triggered creation
of some built-in manifest?  Can you try skipping the gui and doing instead
an nmake -f makefile.win clean  and  nmake -f makefile.win installr ?  This
won't introduce any new 'features' contained in VisualStudio 2005, which could
be introduced by converting the .dsp's into .vcproj's.

> I don't see any other obvious problems in the Dependency Walker.  All
> the dll's in the "Module In List", except the first 17, have little hour
> glass icons next to them.  I don't know if that is an issue or not.

Hour glass I presume is delay-load.  You are looking for red icons in
the function or modules view, which indicate modules or entry points
which could not be resolved.

> I tried running depends.exe on the working box and I noticed the
> following in the bottom.  
> 
> 	Warning: At least one module has an unresolved import due to a
> missing export function in a 	delay-load dependent module.

This is normal.  The kernel itself has some of these conditions.

> One thing I know is different between the XP boxes is that the working
> (and build) XP box has SP2 and the nonworking one doesn't?  Any
> possibility that's an issue?  Any other input would be welcome.  Thanks.


Mime
View raw message