httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "William A. Rowe, Jr." <wr...@rowe-clan.net>
Subject Re: [vote] 2.2.0 tarballs
Date Thu, 01 Dec 2005 00:39:30 GMT
Colm MacCarthaigh wrote:
> On Wed, Nov 30, 2005 at 09:22:58PM +0000, Nick Kew wrote:
> 
>>Can someone clarify: what happens *by default* if APR 1.0/1.1 is
>>found on a target machine?  If it tries to build against that, I'd
>>support a -1.  If it does something sensible - which could be emitting
>>an error message and refusing to build - I'd not worry.
> 
> It refuses to configure, you need to go build apr/apu 1.2 somewhere and
> reconfig with the --with-apr(-util) options.

Ok, now what the heck?

[wrowe@s170 httpd-2.2]$ configure: error: APR-util version 1.2.0 or later is 
required
./configure --prefix=/usr/local --with-apr=srclib/apr 
--with-apr-util=srclib/apr-util
checking for chosen layout... Apache
[...]
checking for APR version 1.2.0 or later... yes
checking for APR-util version 1.2.0 or later... no
configure: error: APR-util version 1.2.0 or later is required

[wrowe@s170 httpd-2.2]$ ls -al srclib total 48
drwxrwxr-x   4 wrowe wrowe 4096 Nov 30 18:32 .
drwxrwxr-x  12 wrowe wrowe 4096 Nov 30 18:34 ..
lrwxrwxrwx   1 wrowe wrowe   19 Nov 30 18:32 apr -> /local0/asf/apr-1.2
lrwxrwxrwx   1 wrowe wrowe   24 Nov 30 18:32 apr-util -> /local0/asf/apr-util-1.2
[...]

[wrowe@s170 httpd-2.2]$ grep VERSION srclib/apr-util/apu-1-config
APRUTIL_MAJOR_VERSION="1"
APRUTIL_DOTTED_VERSION="1.2.3"

Explanations?

Mime
View raw message