httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Max Bowsher <>
Subject Re: Suggest renaming mod_authz_host to mod_access_host
Date Sat, 26 Nov 2005 11:47:43 GMT
Hash: SHA1

Justin Erenkrantz wrote:
> --On November 25, 2005 1:08:12 PM +0000 Max Bowsher <> wrote:
>> Is is really appropriate to lock in an inaccurate and confusing module
>> name for the entire 2.2.x era, just to avoid another beta/RC ?
> Good grief.  mod_authz_host is *far* more accurate and less confusing
> than mod_access.

Could you help me understand why you hold this opinion, please?

The reason I hold my opinion is that my understanding of authorization
is that it is the granting of access based on user identity, which is
not what this module does.

Also, this module does more than purely host-based access.

> Once again, I'm against renaming this module.  If we do the authz
> rewrite we have discussed on the list recently (the last time this
> rename was brought up), it really *will* be mod_authz_host and we'd have
> flipped the module name for no reason.

Isn't it kind of weird and very premature to change the name of a module
in 2.2, when the rewrite will not occur until 2.4?

Letting 2.2 go out with the name mod_authz_host, would effectively be
flipping the name from the well-established 1.3/2.0 mod_access for a
reason which has not yet occurred.

> Again, for those who don't actually read the mailing list and just
> randomly post stuff, the rewrite we discussed on list would combine the
> access_checker and auth_checker hook into one hook - which is how
> authorization should be partitioned anyhow.  -- justin

I have been present on this list for only a matter of months - I freely
admit that I may not know about historical conversations.

However, regardless of any rewrite which may take place in the future, I
am suggesting that the name of the module in 2.2 should respect its role
in 2.2, not its role after some future rewrite, which would not appear
in a release until 2.4 at the earliest.

Version: GnuPG v1.4.1 (Cygwin)


View raw message