httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Max Bowsher <ma...@ukf.net>
Subject Re: Suggest renaming mod_authz_host to mod_access_host
Date Fri, 25 Nov 2005 13:08:12 GMT
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Joshua Slive wrote:
> Joost de Heer wrote:
> 
>>> access control:
>>>   is this request permitted, based on where it is being made from
>>
>>
>>
>> In other words, is the host from which the request comes, authorised
>> to make this request? Hence mod_authz_host.
> 
> 
> I tend to agree that the new name is confusing.  It is theoretically
> possible to have host authz integrated into our system ("Require host
> .apache.org", for example), but it isn't designed that way.  But the new
> name seems to suggest that it is part of the same system.
> 
> And note that any name involving "host" is also a little deceptive since
> the module allows control based on arbitrary env variables, and hence
> arbitrary request headers.
> 
> But this discussion is moot if if 2.1.10 beta becomes 2.2.0 because we
> shouldn't change a module name after release.

Is is really appropriate to lock in an inaccurate and confusing module
name for the entire 2.2.x era, just to avoid another beta/RC ?

Max.

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.1 (Cygwin)

iD8DBQFDhwy8fFNSmcDyxYARAiViAJ9M73vR1/FXgm6VAWjT+ajgvTT66QCgo6z9
yekcO+uCoiPx43kgkwnZv4A=
=mEbp
-----END PGP SIGNATURE-----

Mime
View raw message