httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "William A. Rowe, Jr." <>
Subject Re: Suggest renaming mod_authz_host to mod_access_host
Date Fri, 25 Nov 2005 10:43:15 GMT
Joshua Slive wrote:
> Joost de Heer wrote:
>>> access control:
>>>   is this request permitted, based on where it is being made from
>> In other words, is the host from which the request comes, authorised 
>> to make this request? Hence mod_authz_host.
> I tend to agree that the new name is confusing.  It is theoretically 
> possible to have host authz integrated into our system ("Require host 
>", for example), but it isn't designed that way.  But the new 
> name seems to suggest that it is part of the same system.

Perhaps the real issue is that Satisfy/Allow/Deny is the confusing part,
and these should all be rolled into Require ?



View raw message