httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joshua Slive <>
Subject Re: Suggest renaming mod_authz_host to mod_access_host
Date Thu, 24 Nov 2005 21:59:41 GMT
Joost de Heer wrote:
>> access control:
>>   is this request permitted, based on where it is being made from
> In other words, is the host from which the request comes, authorised to 
> make this request? Hence mod_authz_host.

I tend to agree that the new name is confusing.  It is theoretically 
possible to have host authz integrated into our system ("Require host", for example), but it isn't designed that way.  But the new 
name seems to suggest that it is part of the same system.

And note that any name involving "host" is also a little deceptive since 
the module allows control based on arbitrary env variables, and hence 
arbitrary request headers.

But this discussion is moot if if 2.1.10 beta becomes 2.2.0 because we 
shouldn't change a module name after release.


View raw message