httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nick Kew <n...@webthing.com>
Subject Re: Suggest renaming mod_authz_host to mod_access_host
Date Sat, 26 Nov 2005 09:56:18 GMT
On Saturday 26 November 2005 07:11, Justin Erenkrantz wrote:
> --On November 25, 2005 1:08:12 PM +0000 Max Bowsher <maxb1@ukf.net> wrote:
> > Is is really appropriate to lock in an inaccurate and confusing module
> > name for the entire 2.2.x era, just to avoid another beta/RC ?
>
> Good grief.  mod_authz_host is *far* more accurate and less confusing than
> mod_access.
>
> Once again, I'm against renaming this module.

Fine.  It's mod_access in 1.x and 2.0.  The users expect mod_access.
And it hasn't actually changed in any significant manner.  So that's
mod_access, then.

> If we do the authz rewrite 

Then that becomes the time to propose a name change away from mod_access.

> we have discussed on the list recently (the last time this rename was
> brought up), it really *will* be mod_authz_host

Discussed?  I don't recollect anything more than a vague passing reference,
in about the same level of detail as this post.

> and we'd have flipped the 
> module name for no reason.

That's what renaming to mod_authz_host does, and what some of us oppose.

> Again, for those who don't actually read the mailing list and just randomly
> post stuff, the rewrite we discussed on list would combine the
> access_checker and auth_checker hook into one hook - which is how
> authorization should be partitioned anyhow.  -- justin

But we haven't done any such thing.  If and when we do - and I have yet to see
your proposals for implementing Satisfy logic in a single hook - then a change
to something like, say, mod_authz_host, might merit discussion.

-- 
Nick Kew

Mime
View raw message