httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Colm MacCarthaigh <c...@stdlib.net>
Subject APR_FIND_APR and minimum version
Date Sun, 13 Nov 2005 12:25:46 GMT

The APR_FIND_APR (and _APU) macro hunts for an installed apr with the
specified major version number, but then later we use APACHE_CHECK_APxVER 
to insist on a minor version too.

Wouldn't it make more sense for the APR_FIND_APR macro to only return
aprs of the minimum version we will use anyway?

The current behaviour can lead to problems; If a user has apr 1.0 or 1.1
installed in any of the places the macro looks, httpd will be
unbuildable, and the only way to fix it is to manually install apr >=
1.2. 

-- 
Colm MacCárthaigh                        Public Key: colm+pgp@stdlib.net

Mime
View raw message