httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "William A. Rowe, Jr." <wr...@rowe-clan.net>
Subject Re: Issues for 2.1.8
Date Tue, 20 Sep 2005 21:58:05 GMT
Colm MacCarthaigh wrote:
> 
> Sometimes things are marked experimental not because they are unstable
> in the sense that they contain a disproportionate ammount of bugs we
> have yet to notice, but rather are unstable in the sense that their
> behaviour or API may change in future versions - because the developers
> havn't quite got a feel for what might be optimal in the majority case
> yet.

And all the more reason they can't exist in stable.  You *CAN'T* change
the API of any shipped module, because you are forced to bump the module
major if the resulting change is ABI-incompatible.  That hurts every
third party installed module, not simply the affected module.



Mime
View raw message