httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Brian J. France" <l...@firehawksystems.com>
Subject new/update mod_smtpd modules
Date Fri, 30 Sep 2005 13:54:05 GMT
Here are some new or update mod_smtpd modules:

http://www.brianfrance.com/software/apache/

mod_smtpd_auth.tar.gz:
	mod_smtpd_auth - core auth module
	mod_smtpd_authm_plain - auth method plain
	mod_smtpd_authm_login - auth method login
	mod_smtpd_authm_crammd5 - auth method crammd5
	mod_smtpd_authm_digestmd5 - auth method digestmd5
	mod_smtpd_authv_dbd - auth verify/lookup via dbd

	I have rewritten this module to use the unrecognized_command hook.  It 
uses defines a hook for methods and a hook for lookups and all method 
code was split off into their own module.

mod_smtpd_access.tar.gz:
	mod_smtpd_access - core access module - connection, greeting, from, to
	mod_smtpd_accessl_dbd - lookup module via dbd

	After finishing the auth rewrite I like the way it worked so I did the 
same for the access module.  mod_smtpd_access now has a lookup hook 
that accessl modules can use to plugin.  I will be adding a relay look 
up once we have some way of setting relaying is allowed.

Warning: apreq has problems with multi-line headers and will core dump 
when it gets them (has this been fixed?)

mod_smtpd_clamd.tar.gz
	This is a module that sends the mail to clamd on the data_post hook.  
It only works with TCP connections to clamd because apr doesn't support 
unix domain sockets.  Currently this module will bounce mail with 
virus, but there is a option to not reject them.  More features to come 
like adding headers, rewriting subject and anything else I can come up 
with.

mod_smtpd_spamd.tar.gz
	This is a module that sends the mail to spamd on the data_post hook.  
Currently this module will bounce mail that is spam if it over the spam 
threshold + reject_level. More features to come like adding headers, 
rewriting subject lines, etc.

mod_smtpd_load.tar.gz
	This module just check the load on the server and can temporarily deny 
connections.

Any news on the mod_ftp import?  I can't seem to get at the needed 
ssl_init_ssl_connection from mod_ssl.  I have even tried to dlsym it 
from the mod_ssl handle and I just get back NULL (of course this is on 
my powerbook which doesn't break on dlopen so dlsym might not work 
either).  There must be a different way to upgrade a socket to ssl.

Brian


Mime
View raw message