httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joe Orton <jor...@redhat.com>
Subject Re: which apr(-util) versions for 2.2.x?
Date Tue, 27 Sep 2005 13:47:39 GMT
On Mon, Sep 26, 2005 at 02:52:21PM -0700, Justin Erenkrantz wrote:
> --On September 24, 2005 9:58:26 AM -0700 Paul Querna <chip@force-elite.com> 
> wrote:
> 
> >Actually, we are getting to the point were I would rather just have a
> >hard depends on APR >= 1.2.0
> 
> How about emitting a warning at configure-time if less than our latest 
> recommended version (say 1.2.0)?  I would like to ensure httpd 2.2 builds 
> against apr/apr-util 1.0.0.  -- justin

I think it would actually be sensible at this point to require 
apr/apr-util >= 1.2.0 across the board.

mod_dbd already requires apu-1.2; the event MPM already requires 
apr-1.1.  It would allow unconditional use of things like the new printf 
format in apr-1.2, apr_brigade_insert_file() from apu-1.2, etc.

joe

Mime
View raw message