httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jim Jagielski <...@jaguNET.com>
Subject Re: proxy balancer hook (Was: Re: LoadModule questions on WIN32)
Date Tue, 06 Sep 2005 20:49:32 GMT
Hmmm.... My tests have all been http:

<Proxy balancer://foo>
  BalancerMember http://www.google.com:80 loadfactor=1
  ProxySet lbmethod=bytraffic
</Proxy>

ProxyPass /bat/ balancer://foo/

Weird... Thanks for the feedback!

r.pluem@t-online.de wrote:
> 
> 
> Jim Jagielski wrote:
> > Can anyone else recreate the core dumps that Mladen is seeing with
> > the balancer in 2.1.7-beta? The httpd-test perl framework has a simple
> > test for it.
> > 
> 
> I can confirm Mladens core dumps. I used the latest revision from svn
> and did the following:
> 
> ./configure --prefix=/usr/src/apache/apache_trunk \
>             --with-mpm=worker \
>             --enable-so \
>             --enable-mods-shared=all \
>             --enable-proxy=shared \
>             --enable-proxy-balancer=shared \
>             --enable-proxy-http=shared \
>             --enable-proxy-ajp=shared
> 
> make
> make install
> 
> 
> I added the following lines to the default httpd.conf
> 
> LoadModule proxy_module modules/mod_proxy.so
> LoadModule proxy_connect_module modules/mod_proxy_connect.so
> LoadModule proxy_ftp_module modules/mod_proxy_ftp.so
> LoadModule proxy_http_module modules/mod_proxy_http.so
> LoadModule proxy_ajp_module modules/mod_proxy_ajp.so
> LoadModule proxy_balancer_module modules/mod_proxy_balancer.so
> 
> <Proxy balancer://cluster>
>     BalancerMember ajp://localhost:8009
> </Proxy>
> 
> ProxyPass /servlet-examples/ balancer://cluster//servlet-examples/
> 
> Calling http://127.0.0.1/servlet-examples
> 
> resulted in:
> 
> [Tue Sep 06 22:11:53 2005] [notice] child pid 30700 exit signal Segmentation fault (11)
> 
> Stacktrace:
> 
> 
> #0  0x00000000 in ?? ()
> #1  0x403bca71 in find_best_worker (balancer=0x4083b94c, r=0x4083b950)
>     at mod_proxy_balancer.c:379
> #2  0x403bccee in proxy_balancer_pre_request (worker=0x4083b94c,
>     balancer=0x4083b950, r=0x8171758, conf=0x80f2ed0, url=0x4083b954)
>     at mod_proxy_balancer.c:511
> #3  0x4039a2f9 in proxy_run_pre_request (worker=0x4083b94c,
>     balancer=0x4083b950, r=0x8171758, conf=0x80f2ed0, url=0x4083b954)
>     at mod_proxy.c:1947
> #4  0x4039cafe in ap_proxy_pre_request (worker=0x4083b94c,
>     balancer=0x4083b950, r=0x8171758, conf=0x80f2ed0, url=0x4083b954)
>     at proxy_util.c:1325
> 
> System:
> 
> glibc-2.2.5
> Linux euler 2.4.21-20050503-ruediger #2 Tue May 3 12:40:08 CEST 2005 i686 unknown
> 
> Putting
> 
> LoadModule proxy_balancer_module modules/mod_proxy_balancer.so
> 
> before
> 
> LoadModule proxy_module modules/mod_proxy.so
> 
> in httpd.conf results in
> 
> httpd: Syntax error on line 101 of /usr/src/apache/apache_trunk/conf/httpd.conf: Cannot
load
> /usr/src/apache/apache_trunk/modules/mod_proxy_balancer.so into server:
> /usr/src/apache/apache_trunk/modules/mod_proxy_balancer.so: undefined symbol: proxy_module
> 
> So this does not "fix" it either.
> 
> 
> Regards
> 
> Rüdiger
> 


-- 
===========================================================================
   Jim Jagielski   [|]   jim@jaguNET.com   [|]   http://www.jaguNET.com/
                     "Sith happens"  -  Yoda

Mime
View raw message