httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Reid <da...@jetnet.co.uk>
Subject Re: svn commit: r220307 - in /httpd/httpd/trunk/modules: metadata/mod_setenvif.c ssl/mod_ssl.c ssl/mod_ssl.h ssl/ssl_expr_eval.c
Date Tue, 16 Aug 2005 09:13:08 GMT
Joe Orton wrote:
> On Fri, Aug 05, 2005 at 08:00:01PM +0200, Martin Kraemer wrote:
> 
>>On Tue, Aug 02, 2005 at 07:14:10PM +0200, Martin Kraemer wrote:
>>
>>>I wanted something like
>>>
>>>  SSLRequire "committers" in SSLPeerExtList("1.3.6.1.4.1.18060.1");
>>>
>>>to mean "at least one extension with an OID of
>>>1.3.6.1.4.1.18060.1 with a value of 'committers' exists in the
>>>client cert".
>>
>>I'll be on vacation next week, and will send in another patch after
>>that.
> 
> 
> OK, hope you had a good holiday.  I wasn't trying to argue about the 
> semantics just to nitpick the naming.  Having "SSL" in the SSLRequire 
> function is redundant, but not in the context of mod_setenvif.  So, my 
> preference is:
> 
>     SSLRequire "committers" in PeerExtList("1.3.6.1.4.1.18060.1");
> 
>     SetEnvIf SSL_PeerExtList("etc") ...

+1 on the revised naming.

Patch looks OK as well.

david

Mime
View raw message