httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Colm MacCarthaigh <>
Subject Re: [PATCH] Make CacheEnable useful for forward proxies
Date Wed, 17 Aug 2005 01:49:54 GMT
On Tue, Aug 16, 2005 at 06:23:28PM -0700, Justin Erenkrantz wrote:
> > -          CacheDirLevels 5<br />
> > -          CacheDirLength 3<br />
> > +          CacheDirLevels 2<br />
> > +          CacheDirLength 1<br />
> Why are you changing these?  (I don't think it's relevant to this patch.)

Sorry, they slipped in, I'm currently working on a patch to the
mod_cache documentation and a new Caching user guide. I thought I had
cought everything from my diff. 

5 & 3 as defaults are getting caught up in a lot of places, including
mine and PaulQ's talks at ApacheConEU - and well, as I think was pointed
out on the list last week, they're awful default values.

> > +static int uri_hsp_meets_conditions(apr_uri_t filter, apr_uri_t url)
> I find 'hsp' to be rather non-intuitive.  (It took me a bit to figure out what
> it meant.)  How about just uri_meets_conditions?  


> And, why not push the path check to this function?

At some point I think it was purely to lessen the ammount of confusion
by having a 3 argument function with the pathlen's. Passing the
container structure won't work, because they differ for cacheenable and
cachedisable.  I'll just make it a 3-argument function.

> This cache_select_url function probably needs to get a new name.  It may have
> made sense a while ago; but the name doesn't seem to jive with its
> implementation now.  (AFAICT, this change is unrelated to the rest of the
> patch.)

That change is from getting rid of un-used variable compiler warnings.

Colm MacCárthaigh                        Public Key:

View raw message