httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Fields Marshall" <fmarsh...@yahoo.com>
Subject Questions about SSL 0.9.8 and Apache 2.0.54 compiling errors on released versions
Date Fri, 12 Aug 2005 09:28:06 GMT
Hi 

this is my first post to the mailing list asking perhaps a rather simple
question to you apache developers. 

I am writing this email because I see that this will be a common problem
with people trying to compile the latest SSL and Apache.

I think I fit a common scenario -- average webmaster/programmer trying
to install latest released versions of apache with ssl.  Familiar with
webprogramming but not really in C. However still able to Configure,
Make and Make install. 

I have searched the net and read the faq but no comprehensive
information exists perhaps I don't know how to use the patch command
well maybe this is causing problems.

I have installed and compiled OpenSSL 0.9.8 and then started to compile
apache now I am getting the `PEM_F_DEF_CALLBACK' undeclared error.

I have researched this and have found reference to patch file in email
archive but I have been unable to apply this patch to get something
compiled.

When I run the patch command in httpd/modules/ssl directory

patch -p0 ssl_toolkit_compat.h patchfile

patch: **** Only garbage was found in the patch input.

Could someone please point me in the right direction or a faq on how to
properly patch this.  

 I tried the latest version from CVS but wasn't able to configure it in
the normal manner.

I can see this being a common problem/scenario that is one reason why I
am posting this.

Thanks in advance for help

Fields


Mime
View raw message