httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Brad Nicholes" <BNICHO...@novell.com>
Subject Re: Patch for 2.0.54 + OpenSSL 0.9.8
Date Wed, 06 Jul 2005 20:04:26 GMT
I'm running into the same const problem here as well on the calls to d2i_X509() and d2i_PrivateKey().
 Add these to your patch reworking.

Index: ssl_engine_init.c
===================================================================
--- ssl_engine_init.c	(revision 209481)
+++ ssl_engine_init.c	(working copy)
@@ -719,7 +719,7 @@
 {
     SSLModConfigRec *mc = myModConfig(s);
     ssl_asn1_t *asn1;
-    unsigned char *ptr;
+    const unsigned char *ptr;
     const char *type = ssl_asn1_keystr(idx);
     X509 *cert;
 
@@ -757,7 +757,7 @@
 {
     SSLModConfigRec *mc = myModConfig(s);
     ssl_asn1_t *asn1;
-    unsigned char *ptr;
+    const unsigned char *ptr;
     const char *type = ssl_asn1_keystr(idx);
     int pkey_type = (idx == SSL_AIDX_RSA) ? EVP_PKEY_RSA : EVP_PKEY_DSA;
     EVP_PKEY *pkey;


>>> "William A. Rowe, Jr." <wrowe@rowe-clan.net> Wednesday, July 06, 2005 12:06:45
PM >>>
At 12:44 PM 7/6/2005, William A. Rowe, Jr. wrote:
>At 12:10 PM 7/6/2005, Brad Nicholes wrote:
>>-    sess = d2i_SSL_SESSION(NULL, &ucpData, nData);
>>+    sess = d2i_SSL_SESSION(NULL, (const UCHAR**)&ucpData, nData);
>
>UCHAR?  Sure that isn't a Netware-ism?

My bad, I'm seeing it.

>Otherwise, +1 to this additional patch.  Testing now.

Issue; you toggled from one to the other - so now we have failures
in 0.9.7 and not 0.9.8.  Working out a better patch now.

Bill




Mime
View raw message