httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From steve johnson <aces...@yahoo.com>
Subject Re: Starting from scratch with lucene4c/mod_mbox
Date Tue, 26 Jul 2005 20:32:46 GMT
Update:

By using the trunk version of apr I got lucene4c to
build.  By deleting the liblucene4c.la file I got
mod_mbox to build using lucene4c.  Now when I start
the httpd it dumps core.  Here is a stack trace.  Any
suggestions about next steps would be appreciated.

[Switching to Thread -1210235808 (LWP 30968)]
0xb71a83b0 in _Jv_RegisterClassHookDefault () from
/usr/lib/libgcj.so.6
(gdb) bt
#0  0xb71a83b0 in _Jv_RegisterClassHookDefault () from
/usr/lib/libgcj.so.6
#1  0xb71a8958 in _Jv_RegisterClasses () from
/usr/lib/libgcj.so.6
#2  0xb7cac7a1 in frame_dummy () from
/usr/local/lucene4c/lib/liblucene4c.so
#3  0xb7cac41c in _init () from
/usr/local/lucene4c/lib/liblucene4c.so
#4  0xb7ff61ce in _dl_catch_error () from
/lib/ld-linux.so.2
#5  0xb7ff62ba in _dl_init () from /lib/ld-linux.so.2
#6  0xb7edd2b2 in _dl_open () from /lib/tls/libc.so.6
#7  0xb7ff6016 in _dl_catch_error () from
/lib/ld-linux.so.2
#8  0xb7edced6 in _dl_open () from /lib/tls/libc.so.6
#9  0xb7f0b038 in dlopen () from /lib/tls/libdl.so.2
#10 0xb7ff6016 in _dl_catch_error () from
/lib/ld-linux.so.2
#11 0xb7f0b4a6 in dlerror () from /lib/tls/libdl.so.2
#12 0xb7f0afe4 in dlopen () from /lib/tls/libdl.so.2
#13 0xb7fa32d3 in apr_dso_load (res_handle=0xbffff868,
    path=0x8116168
"/usr/local/apache2/modules/mod_mbox.so",
pool=0x80bc0a8) at dso.c:138
#14 0x0807e010 in load_module (cmd=0xbffffa38,
dummy=0xbffff8f0,
    modname=0x8116140 "mbox_module",
filename=0x8116150 "modules/mod_mbox.so")
    at mod_so.c:240
#15 0x08080cb6 in invoke_cmd (cmd=0x80a77c0,
parms=0xbffffa38, mconfig=0xbffff8f0,
    args=0x80ff1da "") at config.c:797
#16 0x0808155e in ap_build_config_sub (p=Variable "p"
is not available.
) at config.c:1335
#17 0x080819ce in ap_build_config (parms=0xbffffa38,
p=0x80bc0a8, temp_pool=0x80fd1a8,
    conftree=0x80b2c48) at config.c:1127
#18 0x080820d0 in process_resource_config_nofnmatch
(s=0x80c0800, fname=Variable "fname" is not available.
) at config.c:1513
#19 0x08082438 in ap_process_resource_config
(s=0x80c0800,
---Type <return> to continue, or q <return> to quit---
    fname=0x80f8d00
"/usr/local/apache2/conf/httpd.conf",
conftree=0x80b2c48, p=0x80bc0a8,
    ptemp=0x80fd1a8) at config.c:1549
#20 0x08082c1f in ap_read_config (process=0x80bc0a8,
ptemp=0x80fd1a8,
    filename=0x80a8416 "conf/httpd.conf",
conftree=0x80b2c48) at config.c:1892
#21 0x08084beb in main (argc=2, argv=0xbffffcd4) at
main.c:589


--- steve johnson <aces4me@yahoo.com> wrote:

> I've tried so many permutations that I decided to
> start again from scratch building a
> mod_mbox/lucene4c
> development environment.
> 
> new httpd ver 2.0.54 (built with the apr that comes
> with the tarball)
> 
> new apr ver 1.1.1 (built w
> --enable-experimental-libtool)
> 
> new apr-util 1.1.2
> 
> new version of mod_mbox (which seems to work when
> tested)
> 
> now I try to build the gcj-backend branch of
> lucene4c
> with my apr version 1.1.1 and I get this error
> message.
> 
> Can not find suitable object file for
> src/util/exception.lo
> make[1]: *** [src/util/exception.lo] Error 1
> make[1]: Leaving directory `/myth/steve/lucene4c'
> make: *** [all] Error 2
> 
> I know I have build lucene4c without error in the
> past
> (mod_mbox wouldn't build against it but lucene4c
> built
> without error).  What the heck am I doing wrong?  
> 
> Sept 1 is coming up fast and I have yet to get a
> working environment built that I can test any
> changes in.
> 


Mime
View raw message