httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Georg v. Zezschwitz" <...@2scale.de>
Subject Patch for 2.0.54 + OpenSSL 0.9.8
Date Tue, 05 Jul 2005 12:32:48 GMT
Hi,

the OpenSSL team will pretty soon release 0.9.8 as stable release.

However, currently 2.0.54 cannot be built with 0.9.8beta6, as
a pem.h-definition has changed. The OpenSSL-team considers this
renaming as a bug correction, so compilation of mod_ssl will
go on to fail.

OpenSSL 0.9.8 will introduce SSL compression (which has in
principle been defined since SSLv3, however, concrete compression
methods like DEFLATE were "RFCed" in May 2004).

I have attached a patch to make mod_ssl compile with OpenSSL 0.9.8,
and also added an SSL variable "SSL_COMP_METHOD" to allow logging
(and other usages) of the negotiated compression method.

Moreover, I have - to my best knowledge - extended the documentation.

Could anybody check this and decide if to include?
I guess quite some confusion will happen if OpenSSL 0.9.8 is
finally out and using it with Apache 2.0.54 fails.

Also, please don't kill the messenger :-) - it is not my decision
to change the OpenSSL include file definition...

Regards,


Georg v.Zezschwitz

Mime
View raw message