httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From NormW <no...@bocnet.com.au>
Subject HTTPD 2.1 (Head) Build issues for NetWare...
Date Thu, 16 Jun 2005 09:53:35 GMT
Greetings All,
Trying to build Apache 2.1 (head) for NetWare on a Win2K box and get the 
following error:

> Compiling ssl_expr.c
> Compiling ssl_expr_eval.c
> process_begin: CreateProcess((null), yacc ssl_expr_parse.y, ...) failed.
> make (e=2): The system cannot find the file specified.
> make[2]: *** [ssl_expr_parse.c] Error 2
> make[1]: *** [ssl] Error 2
> make: *** [modules] Error 2

Hopefully this is a bug and I don't need another cygwin tool?... Using 
OpenSSl 0.9.7g and WinSockets...

If I set USE_STDSOCKETS=1 I then get a failure building logresolve:

> Generating Release.o\logres_link.opt
> Linking Release.o/logres.nlm
> ### mwldnlm Linker Error:
> #   Undefined symbol: 'WS2_32_gethostbyaddr'
> #   referenced from 'cgethost' in logresolve.o
> ### mwldnlm Linker Error:
> #   Undefined symbol: 'WSAGetLastError'
> #   referenced from 'cgethost' in logresolve.o
> #   referenced from 'cgethost' in logresolve.o
> #   referenced from 'cgethost' in logresolve.o
> ### mwldnlm Linker Error:
> #   Undefined symbol: 'WS2_32_inet_ntoa'
> #   referenced from 'cgethost' in logresolve.o
> #   referenced from 'cgethost' in logresolve.o
> #   referenced from 'stats' in logresolve.o
> #   referenced from 'cgethost' in logresolve.o
> ### mwldnlm Linker Error:
> #   Undefined symbol: 'WS2_32_gethostbyname'
> #   referenced from 'cgethost' in logresolve.o
> ### mwldnlm Linker Error:
> #   Undefined symbol: 'WS2_32_inet_addr'
> #   referenced from 'main' in logresolve.o
> 
> Errors caused tool to abort.

I can't even build APR with the June'05 LibC but that's another story.

Regards,
Norm


Mime
View raw message