httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joe Orton <jor...@redhat.com>
Subject Re: Include Paths, was Re: error
Date Mon, 27 Jun 2005 19:55:12 GMT
On Mon, Jun 27, 2005 at 12:41:42PM -0700, Paul Querna wrote:
> Joe Orton wrote:
> > and then upload the preprocessed output "prefork.o" somewhere?  Possibly 
> > you're picking up an installed mpm.h which was generated for a different 
> > MPM, or something like that.
> 
> Actually, I have been hitting this myself recently with trunk.
> 
> I was picking up the an existing ap_listen.h.  This is a problem, since
> the Listen directive was changed from 1 arg to argv,
> 
> This happened since I was installing to the same prefix, and
> APR/APR-Util were also installed to this same prefix. We recently
> changed to using an installed APR/APR-Util by default, which means those
> directories now get added to the include path, and wham, it includes the
> installed ap_listen.h first.
> 
> Should just be some build hackery to make sure our include directory is
> always first.

A while back configure on the trunk was changed to add the `ap*-config 
--includes` output much later in the INCLUDES, which solved most cases 
like this.

Certainly that much looks OK for me here with separate APR/util builds; 
-I$(top_srcdir)/include is much earlier than the external include 
directories; so if you're seeing that specific problem it needs further 
investigation - what does your INCLUDES look like?

joe


Mime
View raw message