httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Henri Gomez <henri.go...@gmail.com>
Subject Re: Syntax error during HTTP2 reload
Date Tue, 01 Mar 2005 09:04:03 GMT
Nobody to wonder about this bug ?



On Mon, 28 Feb 2005 10:45:36 +0100, Henri Gomez <henri.gomez@gmail.com> wrote:
> Hi to all,
> 
> Apache 2 (2.0.48/2.0.49) got problems at restart time (SIGUSR1) when
> rotating its log.
> 
> [Thu Feb 24 04:15:11 2005] [notice] Apache/2.0.48 (Linux/SuSE)
> configured -- resuming normal operations
> [Fri Feb 25 04:15:15 2005] [notice] SIGUSR1 received.  Doing graceful restart
> Syntax error on line 113 of /etc/apache2/server-tuning.conf:
> Invalid command 'BrowserMatch', perhaps mis-spelled or defined by a
> module not included in the server configuration
> 
> Here is the part of configuration file (/etc/apache2/server-tuning.conf) :
> 
> ==> BrowserMatch "Mozilla/2" nokeepalive
> BrowserMatch "MSIE 4\.0b2;" nokeepalive downgrade-1.0 force-response-1.0
> BrowserMatch "RealPlayer 4\.0" force-response-1.0
> BrowserMatch "Java/1\.0" force-response-1.0
> BrowserMatch "JDK/1\.0" force-response-1.0
> 
> The syntax is correct, since when restarted the apache2 run without problem.
> 
> We saw this bug on our productions serveurs, one running under SUSE
> SLES 9.0 (kernel 2.6) and the second SUSE 9.1 (kernel 2.4).
> 
> On SLES 9.0, Apache is 2.0.49, on Suses 9.1 it's 2.0.48.
> 
> It's seems the problem occurs will Apache receive the SIGUSR1 and is
> also handling requests  (forwared to Tomcat via mod_jk 1.2.5 and
> 1.2.6).
> 
> Apache2 is running in worker mode;
> 
> Thanks for your help
>

Mime
View raw message