httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From dean <dean_mas...@swiftdsl.com.au>
Subject Re: 2.1.3 mod_disk_cache partial responses
Date Tue, 01 Feb 2005 13:25:16 GMT
Justin Erenkrantz wrote:
> On Sun, Jan 30, 2005 at 10:11:44PM +1100, dean wrote:
> 
>>Ive enabled mod_disk_cache in the 'stock-standard' httpd.conf, and 
>>cached pages come back wrong (missing images & css)
>>Ive found a bugzilla report that explained the exact same behaviour [Bug 
>>31486].
> 
> 
> Are you using the proxy by any chance? 
Yes, sorry I forgot to mention that.
> 
> The error message in #31486 has nothing directly to do with mod_cache as
> mod_cache will DECLINED a response if the on-disk files are missing.  So, that
> analysis is incorrect somehow.  (I've added some comments to that PR.)
> 
> 
>>By looking at the headers, cached images return 206 Partial Response.
> 
> 
> mod_disk_cache would never cache a 206 Partial Response sent via the proxy.
> Only the byteranges will, and that is independent of mod_*_cache.  (I verified
> that byterange responses work correctly.)
> 
> Can you please capture a specific set of requests and responses at the network
> layer?  What browser and OS are you using?


Ive just tried few different scenarios and Im completely confused. Here 
are my steps, Im using Firefox extension LiveHeaders to view headers:
1. clear out the proxy disk cache
2. request google.com.au using Firefox1.0 -> page shows up fine
3. clear out Firefox cache
4. refresh page -> google logo doesnt show up (appears as broken image), 
but live headers shows it as a 200 OK
5. delete temp int. files in IE6
6. request google.com.au using IE6 -> page shows up fine
My first thought was that Firefox has an issue. Then I installed 2.0.53 
as a cache-proxy BUT I couldn't reproduce the above, Google logo loads 
everytime.
Another simple page I tried is news.com.au/wireless.
Steps 1 -3 are same
4. refresh page -> no css applied (liveheaders shows 200 OK), logo 
appears broken (liveheaders show 206 Partial Response)
5. delete temp int. files in IE6
6. enter www.news.com.au/wireless in browser bar -> logo loads fine but 
no css applied
7. hit refresh button -> page loads fine with css & logo
As before, I couldn't reproduce this with 2.0.53

Can you try reproduce this behaviour with 2.1.3 ??
I can capture traffic using tcpdump, but there is so much mess (arp, 
dns, acks etc), is there a filter to clean it up to only show the 
relevant packets.
B.T.W. Im running the proxy on Mandrake 9.1. and testing it from winxp 
Firefox & IE6.

Thanks
Dean


Mime
View raw message