httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Erik Abele <e...@codefaktor.de>
Subject Re: svn commit: r124599 - /httpd/httpd/trunk/modules/config5.m4
Date Tue, 25 Jan 2005 19:22:52 GMT
On 25.01.2005, at 15:21, Joe Orton wrote:

> On Tue, Jan 25, 2005 at 02:09:06PM +0100, Erik Abele wrote:
>> Exactly, this just keeps --with-module consistent with the rest of the
>> build system, in respect to the changes introduced by Joe. (Sorry,
>> Bill, I somehow missed your original mail...)
>
> Actually it doesn't, there was a subsequent change to use "libmod_*.la"
> for statically-linked modules, since creating a "libfoo.la" which is
> linked against a "-lfoo" confuses libtool.

Correct, I somehow missed r103164:
-      libname="lib$1.la"
+      libname="libmod_$1.la"

Will fix this ASAP...

> On 2.0 statically-linked
> modules still use filenames like "mod_*.la", so it's not consistent 
> with
> that either ;)

Also correct and of course doesn't make sense without your changes. 
Will remove the backport vote.

> I wasn't sure: what motivated your change, just consistency?  My 
> changes
> were made to fix issues using as-yet-unreleased versions of libtool.

While extending --with-module I experienced problems like 'The filename 
of a convenience library must have a "lib" prefix' when building 
modules on OS X with libtool-1.5.10, the solution was obviously the 
change from r102381...

Cheers,
Erik

Mime
View raw message