httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Branko ─îibej <br...@xbc.nu>
Subject Re: Trying to build the locking branch on Windows
Date Fri, 10 Dec 2004 04:28:15 GMT
Branko ─îibej wrote:

> Says this:
>
> Linking...
>   Creating library 
> ..\..\..\Release\subversion\mod_dav_svn/mod_dav_svn.lib and object 
> ..\..\..\Release\subversion\mod_dav_svn/mod_dav_svn.exp
> repos.obj : error LNK2001: unresolved external symbol 
> _dav_get_locktoken_list
> ..\..\..\Release\subversion\mod_dav_svn\mod_dav_svn.so : fatal error 
> LNK1120: 1 unresolved externals
> Error executing link.exe.
>
>
> Allright, now: Which version of httpd should I have been linking to? I 
> have 2.0.52.

Oh bah and grumble. It's a mod_dav bug; that function isn't declared 
with DAV_DECLARE, so it doesn't get exported on Windows. Fubar. It's of 
course not enough to fix mod_dav.h, it requires an httpd recompile.

Which means that mod_dav_svn 1.2 will be broken on Wnidows until a new 
version of httpd is released which fixes that error. There are lots of 
other such broken declarations in that header, and I wonder if changes 
get reviewed carefully enough...

The patch is huge (it touches most files in modules/dav/main), and I 
don't have time to make it now. I'll try ti get it out the door, but 
whateer happens, 2.0.53 IMHO should not be released without the fix. At 
least, as far as Subversion is concerned...

-- Brane



Mime
View raw message