httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Enrico Weigelt <weig...@metux.de>
Subject yet another autoconf horrow story (Problem w/ apache-2.0.52 + php-4.3.9: unresolved symbol ap_loaded_modules)
Date Tue, 07 Dec 2004 20:44:36 GMT

After days end days of debugging the undebuggable (=autoshit), 
i've found out, that configure doens't recognize my GNU ld as an
GNU ld and so disables shared libraries silently.
This ended up in libtool generating only static libraries instead
of shared objects.

Passing --with-gnu-ld didn't have any little influence on that.

I've trashed it to use $EGREP (which was detected properly) and now
evryting works fine: .so's are created and third-party modules 
(ie php4) can be loaded properly.

This dawm autoshit again has costed three days of work for me.
And still it has dozens of problems (ie apxs is completely unsusable
for sysroot builds)


We really, really go away from it. 


cu
-- 
---------------------------------------------------------------------
 Enrico Weigelt    ==   metux IT service

  phone:     +49 36207 519931         www:       http://www.metux.de/
  fax:       +49 36207 519932         email:     contact@metux.de
  cellphone: +49 174 7066481
---------------------------------------------------------------------
 -- DSL ab 0 Euro. -- statische IP -- UUCP -- Hosting -- Webshops --
---------------------------------------------------------------------

Mime
View raw message