httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Brad Nicholes" <BNICHO...@novell.com>
Subject Re: A zLib Update....?
Date Tue, 30 Nov 2004 16:05:43 GMT
   NetWare builds against either 1.1.x or 1.2.x.  It just depends on
where you point the ZLIBSDK environment variable at compile time.

Brad

>>> wrowe@rowe-clan.net Tuesday, November 30, 2004 6:52:58 AM >>>
At 01:57 AM 11/30/2004, Justin Erenkrantz wrote:
>--On Tuesday, November 30, 2004 6:53 PM +1100 NormW
<normw@bocnet.com.au> wrote:
>
>>With the recent upgrade of PCRE for Apache 2.1.x, I was curious if
zLib
>>(required for mod_deflate) is mandated at 1.1.4 or could it also be
>>'updated' to the 1.2.1 release (available since Nov'03). A 2.1 build
on
>>Windows for NetWare shows it glues together without issue; are there
any
>>test scripts that one might use to see if it works as expected?
>
>We don't bundle zlib.  So, there's nothing for us to do.  Or, do the
Win32 folks perhaps bundle it?  But, Unix only works off an external
zlib.  -- 

And win32 httpd-2.0 builds only with 1.1.x sources.  httpd-2.1
builds against the zdll1.lib (and requires zlib1.dll), e.g. 1.2.2.

Since zlib1.dll is an 'official format' now - when httpd 2.2 is
released and a hole is found, the user can obtain zlib1.dll right
from their web site rather than waiting for the 'next' httpd rel.

Bill


Mime
View raw message