httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Brian Pane <bri...@apache.org>
Subject Re: PCRE in 2.1/2.2
Date Thu, 18 Nov 2004 01:01:48 GMT
Paul Querna wrote:

> Is there any reason to keep libpcre in the httpd tree?
>
> I believe we should use the PCRE installed on the system.  If its not 
> on the system, the user can install it.  There are several bugs from 
> 3rd party modules that also try to use pcre, and get conflicting 
> symbols because of the version embedded within apache 2.0.
>
> No comments in a week, and Ill start taking it out.
>
> -Paul Querna

About two years ago, I made some performance optimizations to the copy 
of pcre
in the httpd-2.0 tree.  I submitted the diffs to the pcre maintainer, 
but I don't know
if they've made it into a subsequent pcre release.  The changes, as I 
recall, were to
remove some mallocs/frees in the regexec function.  They may or may not 
still be
needed with newer versions of pcre, if the pcre code has changed 
substantially
since then.
<http://marc.theaimsgroup.com/?t=101659005500001>

Brian


Mime
View raw message