httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jean-Jacques Clar" <JJC...@novell.com>
Subject Re: mod_disk_cache directives naming convention
Date Thu, 07 Oct 2004 18:13:00 GMT
>>> justin@erenkrantz.com 10/07/04 11:14 AM >>>
--On Thursday, October 7, 2004 9:08 AM -0600 Jean-Jacques Clar 
<JJCLAR@novell.com> wrote:

>I *really* don't like the M prefix at all.  I'd much prefer us to just
spell 
>the thing out: CacheMem* and CacheDisk* instead of MCache and/or
DCache.  I 
>think a single letter prefix is really ambiguous.  M what?

I am not going to fight you on the prefix. I just want it to be
different for each 
module, that is what I will like to get done here.
I won't probably agree if we use 'Waboozle', and I suggest that the
description 
should with the name of the module like MemCache* and DiskCache* to
make it easier for related directives to be grouped together (sorted).

>If we go through the process of renaming the directives (and I'm +1 to
making 
>it consistent per my first paragraph), I'd like to see us toss all of
the 
>directives we don't implement.
My only worry there is that they will disappear forever instead of
always
annoying us every time we open the c file or look at the doc page.

>BTW, are you volunteering to take the lead on this?  ;-)  -- justin
Yes with pleasure, 
this is why I started the debate.
 
JJ

Mime
View raw message